RouterOS/OpenvpnServer

De GeRgOsNet
  • Pool d'adresses pour le VPN :
/ip pool add name=ovpn-pool ranges=10.16.0.3-10.16.0.200
  • Creation profil vpn:
/ppp profile 
add change-tcp-mss=default comment="" local-address=10.16.0.1 name="openvpn_home" only-one=default remote-address=ovpn-pool use-compression=default use-encryption=required use-vj-compression=default
  • Creation utilisateur :
/ppp secret 
add caller-id="" comment="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name="username" password="password" routes="" service=any


  • Creation serveur openvpn :
/interface ovpn-server server 
set auth=sha1,md5 certificate=router_cert cipher=blowfish128,aes128,aes192,aes256 default-profile=openvpn_home enabled=yes keepalive-timeout=disabled max-mtu=1500 mode=ip netmask=24 port=1194 require-client-certificate=no